[SOLVED] String Input Dropdown Editor AllowedValues Error


#1

Hi,

I’ve pulled the latest docker 2.2.0 today and tried to setup a string input field with dropdown editor as shown in the image. The error “Cannot update field: Properties.AllowedValues: Radio buttons or dropdown list need allowed values” was displayed when I tried to save the field.


#2

Thanks, I will have a look today.


#3

Have you pressed enter, when you added a field? I cannot reproduce it :frowning:


#4

It’s a bit strange…I type keyword then a comma creates a tag, then next ones are added the same by typing comma at the end. Then I save it, that’s where I got the error.
Now I hit enter before clicking on save button, no error.
I collapse the field and reopen the field, the tags disappeared.
I go out of the page, goes back in, still empty tags.
I refresh the page and go back in then the tags are there.
May be I just need to hit enter key before saving and hard refresh to make sure the tags are save correctly. Just that previous version, I never have to hit enter key. Just comma and click save works.
That’s ok, you can close this ticket.
Thanks.


#5

That does not sound like I should close the ticket. if you have the problem, others might have it too. Even though it is not critical, it should be fixed.


#6

I can still not reproduce it. Do you see an error in the Chrome browser logs or so?


#7

Hi,
I got the same issue with dropdown list.


#8

Which version do you use?


#9

I am using the latest docker image v2.2.0.


#10

Okay, can you to reproduce it and write me down the steps for it. I was not able to reproduce it.


#11

yea sure,

  1. Select one schema
  2. Click a ‘Add Field’
  3. Select “String” type
  4. type in field name ex. “test”
  5. Click 'Create and edit field
  6. Go to Editing tab, Choose Dropdown Editor
  7. Type in some values in ‘Allowed Values’ image
  8. Click “Save and close”
  9. error happens

However, once I manually imported the existing JSON with a Dropdown JSON as a new schema, then it worked.


#12

This is what I do. I need more infios about step 7.


#13

I asked a professional tester and she is also not able to reproduce it. Can you try 2.2.1 or 3.0.0?


#14

Dropdown works fine in v3.0.0.
Thank you for your help !


#15