[SOLVED] Sq sync in -t workflow can't associate schemas

I have…

  • [x] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

I have exported a workflow from a squidex app. This workflow has a schema. When this workflow is reimported to a different app with the same schema i get the error

Schema calendars not found.

Also the CLI doesn’t warn/error about unexpected targets and has inconsistent parameter pluralisation (EG -t schemas -t workflow)

Expected behavior

The schema to be imported.


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: cli-v7.16.0


  • [ ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


You are synchronizing schemas and workflows, right?

Yes, Schemas first and then workflow

I have fixed it. The fix is in the build pipeline at the moment.

Do i need to update my CLI?

Yes, exactly. It was a CLI bug.

One last thing @Sebastian. When i do an export of workflows the file name on mac osx is workflow{i}.json. I wasn’t going to report this because I only have one workflow and it works but i supect an integer should have been put into the filename.

Thanks, I have fixed that as well.

This topic was automatically closed after 2 days. New replies are no longer allowed.