[SOLVED] Regression: random 500 sync/create schema

I have…

  • [ ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [x ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

After cloud upgrade REST API calls Synchronize a schema / create schema / update schema rules fails with HTTP 500. It’s strange behavior because it seems totally random. Sometimes i send 5 schema sync requests and all fails and next time fails only one of requests. I do about ~20 requests in short time.

example response data:
{ traceId: '|334b6cb0-4ad48530724be93e.', type: 'https://tools.ietf.org/html/rfc7231#section-6.6.1', statusCode: 500 }
schema data (json) are not changed.

Expected behavior

Work as in previous version.

Minimal reproduction of the problem

POST https://cloud.squidex.io/api/apps/{app}/schemas


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x ] Cloud version

Version: cloud

Browser: N/A

Also when i am trying to create new field or delete schema, sometimes i have error (red) notification XXX reload page.

Thank you.

Hi, it is the same as this: Not able to add fields to schema

I just deployed a potential fix.

1 Like

Yes, it’s solved.
Thank you.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.