[SOLVED] Component - Not a Known Field Validation Error

I have…

  • [x] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Adding a new field to an existing component tied to a single content schema already saved produces a validation error “Not a known field”.

Expected behavior

Save does not throw not a know field validation error.

Minimal reproduction of the problem

Simple app duplicating issue can be seen https://cloud.squidex.io/app/not-a-known-field-bug

  1. Create a component (add a string field called “string1”)
  2. Create a single content schema (add a component field and point to created component)
  3. Go to content and save a test string in the original component.
  4. Go back to schema editor and edit component. Add a new field that is a string called “string2”.
  5. Go back to content and try to save a new value in string2, a validation error appears.


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: latest on both


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


Since this is a validation error, I have no error log to share.

I attempted to use the Json synchronize option for both the component and schema (with delete and recreate fields both checked) but this did not change the result. Note, I set isPublished to false in the json text when doing this to ensure the synchronize had a change to go forward.

Apologies for the updates on original post. I removed the work-around I listed as it doesn’t appear to work in all cases. Not able to reliably reproduce a workaround.

Do you have the json for me?

Thx, it is a caching issue and a architectural flaw. Unfortunately I do not have a fast solution, so it might take a little bit of time to resolve that issue.

Sorry about that, will include in future if find any bugs. In terms of resolve time, no problem.

It is fixed in the master branch


Thank you.

We updated our version, and I can confirm the fix works.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.