[SOLVED] Can clear disabled components fields

I have…

  • [x] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

The ‘Clear’ button is still clickable when the field is disabled and you are able to remove all the components.

Expected behavior

“Clear” button is disabled like other buttons that change content on the page when field is disabled.

Minimal reproduction of the problem

  1. Create schema with a Components field
  2. Create content for that schema including a component or two in the components field and publish
    3a. Assign schema to a workflow that has ‘Prevent updates’ checked against the Published status; OR
    3b. Click ‘Disable in UI’ for the components field
  3. Go back to the content; you can click the ‘Clear’ button and remove that bit of content (after clicking ‘Yes’ in the popup if you haven’t previously selected “Don’t ask again”).


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: Cloud & 7.1.0


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

I raised this last week but I cannot find it as I think it was deleted as the version I had reported it against was 6.9.0 and you have made changes in this area in commits since then (For example [SOLVED] Disabled fields still have x button (clear field content) enabled), but I have retested against latest versions and the bug is still present. It is not a major issue as you cannot save the changes after clearing the field.

It is the same component as the array. I can have a look.

Thanks for fixing this, just tested out latest master branch and it is disabled as expected. Although now I look at it again I have realised that you can still reorder components when the field is disabled…

ARGH :smiley: … will be fixed as well.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.