[SOLVED] Can change publish status in Read permission

I’m submitting a…

  • [ x ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

The user is assign with a role which has read only permission for one of the schema.
The user can publish/unpublish the content which he should only have read permission. See screenshot:

The user can also click Delete action and see the delete confirmation popup but item doesn’t get deleted.

Expected behavior

User with read permission should not be able to change the content status (publish/unpublish/archive/delete) in all the places (listing mode, edit view mode)

Minimal reproduction of the problem

  • Create a role with read permission for one schema
  • Assign a user to the role
  • Go to content section to check the above screenshots action triggers areas


  • [ x ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: 4.3


  • [ x ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


Can you show your permissions?

Added the role with permissions screenshot under steps to reproduce. ie


Yes, this is somehow weird, I still try to understand why I made it like this.

Solved in current dev version.

1 Like

thank you will test soon.