Email or password not correct


#1

Hello, I have problem with login to Squidex running locally on my Windows 10 machine. I am running it using “docker-compose -f docker-compose-noproxy.yml up -d”

And my .env file looks like this:
SQUIDEX_PROTOCOL=http
SQUIDEX_FORCE_HTTPS=False
SQUIDEX_DOMAIN=localhost
SQUIDEX_ADMINEMAIL=<MY_REAL_EMAIL>
SQUIDEX_ADMINPASSWORD=2W_4n+*qED4D#W9
SQUIDEX_GITHUBCLIENT=
SQUIDEX_GITHUBSECRET=
SQUIDEX_GOOGLECLIENT=
SQUIDEX_GOOGLESECRET=
SQUIDEX_MICROSOFTCLIENT=
SQUIDEX_MICROSOFTSECRET=

But i get message: “Email or password not correct.”

I tried Chrome and Firefox. I also read this closed topic: Unable to log-in with the admin username and password set in .env but as you see I entered very strong password. I tried more types of password which all meets your recommendations but nothing worked :frowning:

There is also no information in log.

Best regards


#2

I will have a look today


#3

Hi Sebastian,
thank you. For better specification - I am using Windows 10 Enterprise (so docker is running in Hyper-V - recommended).

I have done only one change in docker-compose-noproxy.yml:
squidex_mongo has this mounted volume:

volumes:
  - /mongo:/data/db

And of course, there is (empty) folder “mongo” in the same directory as docker-compose file.

Best


#4

Thanks for the information. It should not matter I think.


#5

Sorry, I cannot reproduce it yet. Do you see the user in the database?


#6

I think there is some issue with Mongo. When I removed this:

squidex_mongo:
volumes:
- /mongo:/data/db <----

from my docker-compose it is working. But (logically) Mongo DB is created inside HyperV where docker runs. Maybe there is an issue with exposing/mounting this folder from/to my windows folder :frowning: I will try to more explore.

Thank you


#7

Perhaps you just have to define a windows path?


#8

I am facing this problem:


#9

Have you checked the settings: