Warning about NoFormatter

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [X] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

somehow it keeps throwing a warning like this. The content types somehow is duplicated ‘application/json; charset=utf-8, application/json; charset=utf-8’

I got this warning like 25% of the times. It will be great if I can find a way to get rid of it.


    "stream": "stdout",
    "time": "2023-03-20T14:29:24.258300789Z",
    "logLevel": "Warning",
    "message": "No output formatter was found for content types 'application/json; charset=utf-8, application/json; charset=utf-8' to write the response.",
    "eventId": {
      "id": 2,
      "name": "NoFormatter"
    "contentTypes": "System.Collections.Generic.List`1[System.String]",
    "timestamp": "2023-03-20T14:29:24Z",
    "app": {
      "name": "Squidex",
      "version": "",
      "sessionId": "b28c4a1a-f9cf-4f7b-b8f0-1eba4f9d086c"
    "web": {
      "requestId": "00-fd3b808cd17eefe6662ee4d3f23e9511-8747507c586093a9-01",
      "requestPath": "/api/assets/xxx/975f9b34-892e-4c0c-898d-188f29715fea",
      "requestMethod": "GET"
    "category": "Microsoft.AspNetCore.Mvc.Infrastructure.ObjectResultExecutor",
    "k.container_image": "squidex/squidex:7.4.0"

Expected behavior

no warning

Minimal reproduction of the problem


App Name:

  • [X] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: 7.4.0


  • [ ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


This is the content type, that you define in your client. It is nothing I can do.

I see. thanks for answering

Quick follow-up, we aren’t setting the format right now so that Squidex utilizes webp when there is support for such a conversion at the browser. I can’t find the document on this, but I think I remember this being recommended to kind of automatically switch between the standard image formats (jpg, png) and webp.

Is there a better way for us to be handling this?

The content type is set by the browser automatically. You have to append ?auto=true to get automatic conversion.

Thanks. I think I figured out our issue. We have a old site that also uses some of these assets. I forgot to set the auto=true there in the past. Appreciate your help.

1 Like