URGENT: Missing references

Hi Sebastian,

I have an urgent issue I need some help with.

All of a sudden some references within a schema that were previously defined and working fine are now showing up as “- No Reference -” in the editor, and when I try to set the reference again (using the dropdown list) the desired content is not found. However, when I check the referenced schema the entry I’m trying to reference is present and looks fine.

I tried re-saving the target content, which does seem to make the reference reappear, but after doing that some other references that were present disappeared.

This is happening in our app, “daariz-english0-course”. The schema that references the content is called “topic”, and the specific topic having trouble has our own “id” of “t01”. The referenced content is in a schema called “item”. The reference is nested within a couple of components, and is within a list field. The attached screenshot shows “- No Reference -” for an item that should be “t01_a”.

Please let me know what additional information you need to help diagnose the issue. (The only editing done recently was to change some of the assets that are used by the referenced content.)

We’re days away from launching a mobile app that depends on our Squidex app data, so we are very anxious to get this resolved and understand the cause.

Thanks for your help!

Best,

Barton

1 Like

I think this is what happens:

There is a bug in the references editor which causes it to query all items, and not just the items with the references IDs.

Therefore a query like “give me all latest 100” items is sent to the endpoint and the result does not contain the requested item in some cases.

It is only an UI bug and your API is not affected.

Thanks very much for your speedy reply.

I checked the JSON (from the editor) and see the referenced identity values. I’m having our tools developer (who is using the API to get the content) check to see if there’s an issue on his end.

I could see how your explanation makes sense when a content author tries to change the value of the reference, although I’m not sure it explains our situation because all of the items in the drop-down list are from the correct schema.

Also, for an existing reference with a valid identify value, why wouldn’t the editor be using the identify to retrieve the referenced content when the schema is first opened?

My explanation was wrong:

You are using dropdowns. A dropdown editor loads 100 items and then shows the item that matchs to the referenced ID. But your item is not part of the dropdown. This is stupid because:

  1. It could cause the issue your described.
  2. It always loads all items even it they are not needed.

if you change the editor to a normal reference editor it should work again. There is also a tag input editor, which should work great as well.

I tried changing the editor to tags but it still would not find a valid (existing) item.

Can you please explain further what you mean by changing the editor to a, “normal reference editor”?

I mean the list editor.