Unable to view content or schema on new install of Squidex


#1

Published code from master branch, deployed within IIS.
Configured to use Mongodb for asset store and orleans
Wiped out previous Mongodb databases
Restored an app from another server, created a blank app
Click on Content or Schema, get a red error “Failed to make request”
Log does not show this error message, but shows a series of warnings for Orleans


#2

You can send me the full logs but I cannot help otherwise.


#3

Here is a link to the log file. Thanks

https://drive.google.com/open?id=1_cTlVRwYZ1sIS2xDUwUtAyFh0KBHTtuI


#4

Why have you enabled clustering?


#5

Enable clustering ? Do you mean by using MongoDb in Orleans ? Because the alternative is “Development” ?

I have tried switching back to “Development” but with similar results.


#6

Development is fine. And you said it is the latest version?


#7

The version I pulled down after you fixed the Migrations issue.

When I run locally with npm start and dotnet run… it works. But when I do a Publish and deploy the files under IIS this problem occurs. I replaced the previous version of Squidex with all the previous security intact if that helps?


#8

Strange. Orleans makes a request to itself to check the clustering. Unfortunately you cannot disable it. Can you check the Orleans_Membership Table column in MongoDB and have a look for the IP addresses there?


#9

Actually there are 6 entries in the Orleans_OrleansMembershipV2 table… All with the correct hostname and ip address


#10

What error do you see in the browser?

Does the application stop automatically?


#11

When I click on Content or Schema, I get a red error “Failed to make request” in bottom right hand corner and nothing displays.


#12

I mean in the Browser network tab.


#13

Sorry… there are no http errors, just console errors

UserManager.getUser: user loaded
api/apps:1 Failed to load resource: the server responded with a status of 401 (Unauthorized)
scripts/oidc-client.min.js:1 UserManager.getUser: user not found in storage
app.js?251e253b5582705948a4:2 UserManager.signinSilent: successful, signed in sub: 5d659a3b215c3307245f613f
app.js?251e253b5582705948a4:2 ERROR Error: Uncaught (in promise): e: {“statusCode”:500,“message”:“Failed to make the request.”,“details”:[],“displayMessage”:“Failed to make the request.”}
at F (shims.js?251e253b5582705948a4:2)
at F (shims.js?251e253b5582705948a4:2)
at shims.js?251e253b5582705948a4:2
at r.invokeTask (shims.js?251e253b5582705948a4:2)
at Object.onInvokeTask (app.js?251e253b5582705948a4:2)
at r.invokeTask (shims.js?251e253b5582705948a4:2)
at n.runTask (shims.js?251e253b5582705948a4:2)
at b (shims.js?251e253b5582705948a4:2)
at u.invokeTask [as invoke] (shims.js?251e253b5582705948a4:2)
at i (shims.js?251e253b5582705948a4:2)


#14

Okay, thx. I will setup it on IIS. Perhaps I can reproduce the problem.


#15

Actually, when I run locally using npm start & dotnet run it works fine.

When i publish, navigate to the publish folder and run using dotnet ./Squidex.dll I get the same problem. I copy over the appSettings.config from the Squidex/src/Squidex folder into the publish folder.

Is it an issue with how I’m publishing ?


#16

No, it should be fine. This is how I also deployed it the last time. It is important to set ASPNETCORE_ENVIRONMENT=Production and the urls:baseUrl.


#17

Environment is set, not sure what you mean about urls:baseUrl though ?


#18

You have to set the URL, that is used to reach:

It is here in the app settings: https://github.com/Squidex/squidex/blob/master/src/Squidex/appsettings.json#L13

Please read the page about configuration in the docs.


#19

I think I have decent handle on the configuration… I just wasn’t picking up what you were referencing.

Thanks, appreciate your time on this issue.


#20

I hope I will find the time tomorrow to try it on IIS. It is a few month since I have done it the last time.