Unable to see apps and add contributers to it while uploading backup

It is related to this Ticket - [SOLVED] Unable to access the apps

I don’t see any Apps in my Admin dashboard and when I try to create the app with the same name then it says “App already exists with the same name”. When I try to upload with a fresh new database then a backup is restored but at the last of the logs, it says, “Failed to add the contributor”.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Expected behavior

Minimal reproduction of the problem


  • [-] Self hosted with docker
  • [-] Self hosted with IIS
  • [-] Self hosted with latest version
  • [x] Cloud version

Version: [Latest Free Version downloaded 10 days back]


  • [- ] Chrome (desktop)
  • [ -] Chrome (Android)
  • [- ] Chrome (iOS)
  • [ -] Firefox
  • [- ] Safari (desktop)
  • [- ] Safari (iOS)
  • [- ] IE
  • [- ] Edge

Could you please look into this on a priority?

Have you checken the logs?

Yes checked, and there is no error logged. Not in the logs folder and Event Viewer both.

Is there anything logged? Does logging work in general?

No nothing. Admin section works properly fine, all fresh/new with no apps and teams.

I had 2 apps created with schemas and data. I can send you log after restoration of backup. Please let me know. It doesn’t log anything into the main logs folder.

By default Squidex only logs to stdout, but you can check the web.config how to forward this to a file.

It is creating a log file but not adding any log related to this. Should I send you log file in PM?

Just search for “exception”. I cannot even fin the message “Failed to add the contributor” in the code, which confuses me.

If you go to the user management you can add the permission to see the app. Just add squidex.app.YOUR_APP_NAME

Added the permissions and it didn’t show the App. I tried to create the app with same name and it gave validation error as per image attached. image

I tried to restore again but these are the logs. Last time restoration, it gave error to add the contributor.


In Squidex cloud, there cannot be two apps with the same name. I would try with a different name and see what happens.

@sangramrath @Sebastian
The error/issue is not the App with the same name. Old-created apps are not visible anywhere in the application but still exist behind the scenes which is a main problem.

I want the apps to visible. Even after install the fresh version and restoring the backup. It doesn’t show.
First backup restore shows error of Failed to add contributor and if we try again to restore the backup, it shows error as given in the image below


Could I share my Appsettings and AppSettings.production.json file to take a look??

It is very likely not relevant. Try to get the logs working and then lets see again.

I am not sure, if this is a problem. You can check your database if you have more than one app with the same name that has not the “isDeleted” flag.