Unable to define custom roles within squidex


#1

In your documentation it states that I can create custom roles:
https://docs.squidex.io/concepts/permissions

Unfortunately I am unable to see this in my self hosted instance of squidex even whilst logged in as the administrator.

https://mod-squidex-sandbox.cloudapps.digital

Is this feature still available if so how can I achieve this.


#2

I just checked it in the cloud, which has the newest version and I am able to see the data there.

Can you make a screenshot of the settings menu item?


#3

Here you are :slight_smile:


#4

In the admin view I also can’t see permissions. ( I would upload a screen shot but it contains email addresses)

(app/administration/users)


#5

Have you tried to logout and login again?


#6

Yep just tried this and just tried in a new incognito window but my issue still persists.


#7

In the local storage of your browser should be an entry with an id_token and access_token. Can you send me this via PM?


#8

Yep will do this now.


#9

Thank you. I can still not see the issue. Btw: Which version are you using?

Another thing:

When you reload the UI it also loads all apps with the associated roles. Can you send me the json of this endpoint? The url should be http(s):domain/api/apps


#10

Where can I find out what version I’m using or are you referring to which app I’m currently using?

If the latter I’m currently using the modbenefitscalculatoruat app.

When I try to hit the https://mod-squidex-sandbox.cloudapps.digital/api/apps/ I just get a 500 error.

Anything else I can try?

(note I tried accessing the above url in postman and in the browser)


#11

If you just open the network tab in your browser and reload the UI you should be able to see the result.


#12

ahhh here you are:
[{"name":"modbenefitscalculatoruat","version":67,"id":"93d2e576-1778-4a7a-be1f-84452abee89e","created":"2018-04-12T13:41:37Z","lastModified":"2019-02-19T13:06:29Z","permission":"Owner","planName":"Infinite"},{"name":"flexibleservice","version":64,"id":"2bb10f47-a72f-4c4d-b632-f7e56bad5bf8","created":"2018-04-12T13:41:37Z","lastModified":"2019-01-10T11:57:05Z","permission":"Owner","planName":"Infinite"}]


#13

I would try to migrate to a newer version of squidex, e.g. https://github.com/Squidex/squidex/releases/tag/v1.16.0

Your JSON looks like an older version.


#14

OK cool thanks for your help.