Unable to Create Corporate Emails | Invite sent to User inits new Apps/Dev Instance

Hi Squidex,

We signed up as paid users today. Owner: [sagun@vanna.com]

App: vannatest

Problem: I invited two new users [esther@vanna.com/rebecca@vanna.com](http://esther@vanna.com / rebecca@vanna.com)]

They didnt get access to app: ‘vannatest’ instead they signed up as fresh users with new blank repos to create their own apps. My app ‘vannatest’ was not visible. Is it because the emails where they received invites were corporate ids. Because I sent invite to xyz@gmail.com [i.e GMAIL] addresses it worked just fine. They were able to access the ‘vannatest’ app

I have…

  • [ ] Checked the logs and have provided the logs if I found something suspicious there

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Expected behavior

Minimal reproduction of the problem


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: [VERSION]


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


Sagun Garg

User who was received invite on esther@vanna.com, used Google Suite Login.

Have they logged in with the same email that you have used to invite them?

I checked the event logs. Both, rebecca and esther have been removed again around this time: 2020-04-21T09:30:16Z by sagun@vanna.com

Yes I had to remove them, as I had to send invites on their personal gmail Ids. I am on limited users so decided to remove ester@vanna.com and rebecca@vanna.com.

Now James@vanna.com and phil@vanna.com are facing the same issues :sob:

You can now check phil@vanna.com user specifically when it comes to logs, 1 hr back I got the report that even he can’t see ‘vannatest’ app

Apparently there is a bug for Inside organisation invites based on clinical evidence of all email invites related to *@vanna.com

James as an example has never logged in into Squidex, but right now I cannot understand why phil cannot access it. But the majority of my enterprise users have organization accounts, so I think it is very likey not related.

I have removed and added phil now and I think he should see the app now, but I have no idea yet, why it didn’t work in the first place.

When users are added they are also added to another index that is needed to provide access, but this index was empty for phil. I have no idea yet, why, but I will download the backup tomorrow and try to reproduce it.

Thanks for the patch. I will add esther and rebecca once the root problem is solved. Is it just me or other accounts are also getting affected with this bug

I don’t know, I cannot reproduce it yet. Not even sure yet if it is a bug or a mongodb issue. Have to check everything.

After yesterday night’s patch of removing and re - adding the user Phil (phil@vanna.com, He has ‘Owner’ rights. ). After Logging in is getting this error when he tries to View ‘Content’

Solved for phil@vanna.com after I deliberately flipped roles for the user to manually refresh it. I switched the role to author from owner and then back to owner. It then seemed to work. I don’t know if I would call it a hack…but seems more like a standard CS 101 reboot for that particular functionality which seems to get things working again.

Okay, I am downloading the backup now , but I am not sure if I will find something.

I had a few hiccups in the DB cluster. Looks almost like lost writes or so.

1 Like