The SSL connection could not be established,

I have…

I setup in my machine by run command: docker-compose up -d

my .env:


My appsetting:

    "app": {
        "url": "https://localhost",
        "appName": "first-app",
        "clientId": "first-app:default",
        "clientSecret": "017byv57clkn4un8gh0wbpcgvcqor240yqfupt1xbfkx"

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Error when acccess backend url: https://localhost:5001

AuthenticationException: The remote certificate is invalid because of errors in the certificate chain: PartialChain

Expected behavior

Run example with out error.

Minimal reproduction of the problem

self-sgned SSL cert.


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: 5.0.0


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [x] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Is it possible to login despite corrupted cert? If yes, what i should to set in squidex?

The localhost certificate is only self signed of course, I would just run it without https locally.

Do you use the squidex client library or how do you get the exception?

If the answer is yes:

Create the client manager with the following configurator:

new SquidexOptions
   Configurator = AcceptAllCertificatesConfigurator.Instance


I run Sample.Blog for cSharp, I will getting error above (change config to local)


    "app": {
        "url": "https://localhost",
        "appName": "first-app",
        "clientId": "first-app:default",
        "clientSecret": "017byv57clkn4un8gh0wbpcgvcqor240yqfupt1xbfkx"

If I run example written by Angular It will run without any error (no change config)


I dont know how to config in Squidex backend

It is a frontend topic. You can override the settings here:

I can also update the sample.

How can I setup My own Squidex Blog Sample data in my local, not using

Quick Solution: using instead localhost.

I guess you mean localhost instead of

You can configure all settings here:

If I use localhost in appsetting.json it will get error. If I using it work well

If you use SSL you need a valid certificate chain, this means an authority that proves that the certificate is actually correct. When you buy a certificate or use lets encrypt the certificate is always valid. Also when you use cloudfront or a similar service. But with localhost it is not possible to have valid certificates, only self signed certificates.

Therefore you have to tell the client (it is not only .NET) that the certificate is valid. I have updated the sample with the necessary config.