Strange behavior with local k8s cluster


#1

Dear Sebastian, good morning,

I currently work on CI/CD pipelines to deploy our current solutions and I have one problem :

Here are 2 environments I am using :

  • One local k8s cluster (I have tried with minikube and the built-on docker k8s cluster, and I get the same result. OS : Windows 10 Pro)
  • One AKS (Azure Cluster), use for staging and production

I can deploy without any problem all my containers on AKS, but I each and every time I try to publish to my local cluster, I get this message for my Squidex image :

"Error: failed to start container “squidex”: Error response from daemon: OCI runtime create failed: container_linux.go:348: starting container process caused “exec: “./Squidex”: stat ./Squidex: no such file or directory”: unknown "

  • When I run the same image on docker only it works like a charm.
  • I have tried some others solutions like not using the alpine image and change the entry point command … no luck it couldn’t find dotnet …

I have googled around but so far I didn’t find a solution yet.

If you have any clue of what’s going on I would really appreciate a bit of help as now, I feel a bit stuck.

Thanks a lot for the awesome work you have carried out with Squidex and good day,
Aldric


#2

Can you share your yaml file? BTW: i run the same docker in k8 cluster in Google cloud


#3

Hi Sebastian,

I finally found out why it’s not working. I was trying to use a volume mount associated with a configmap, and the problem comes from my mountPath : "mountPath: /app/ ". but it seems I couldn’t bind it to an existing folder in the container.

I just changed it to /app/secrets and now everything run perfectly !

The worth thing is that the volume get created without any problem but container can’t start at all. So no log and just on meaningless message.

Anyway thanks a lot,
Aldric


#4

Great … good that you solved it, less to do for me :slight_smile: