Squidex 4 - 500.30 Error

Windows 2016
IIS 10
DotNet Core 3.0 Installed


I downloaded the new Squidex version. however, this version does not work within the IIS. Since I always get a 500.30 error message. After closing the message, it is the used port 5001.

Therefore, I have set a new port in the appsettings for the Kestrel.

"Kestrel": {
    "EndPoints": {
        "Http": {
            "Url": "http://localhost:5999"

Now I can go to the cmd dotnet ./Squidex.dll and run in Chrome with this port. However, IIS still does not work with my domain. I still get the same message.

Does Squidex 4 have to be operated as a reverse proxy? Or is there a trick? Other dotnet core 3 applications (mine) work without any problems.

i also had the same problems on another server.

Greetings Andreas

Are you sure that port 5001 is available?

the first server no.
No at the first server. There is still a GPS portal with the Post 5001 running.

That’s why the setting of the port 5999, this is free.

But the second server on which I tested this is the port 5000 and 5001 Free.

You can run it without kestrel and see what happens. Just a dotnet Squidex.dll should work.

that is, only one installation per server can be run? I’ll test tomorrow on a server where there is no installation.

I think when you run ASP.NET Core with the in-process model it should not be a problem. But IIS is not so user friendly when you get startup errors. Therefore my recommendation is to test it without IIS first to see if the configuration is correct. When I google for 500.30 I get results about startup errors.

Just to document it:

So with dotnet ./Squidex.dll everything works fine. not within the IIS.

I will rehearse a bit and see if I can find a solution.

1 Like


Everything works now.

Tonight, backed up all Squidex apps and databases. All installations deleted and now have only one installation with version 4.

Since then everything works. :slight_smile:

Greetings Andreas