[SOLVED] X-Flatten Header broken in v3.0.0


#1

I have…

  • [ ] Checked the logs and have provided uploaded a log file and provided a link because I found something suspicious there.

I’m submitting a…

  • [x] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

When X-Flatten: true and X-Languages: de headers are provided, Squidex-API returns all languages

Expected behavior

API should return the model flattened

Minimal reproduction of the problem

  1. Upgrade to v3.0.0

  2. Create Language

  3. Create Localized Schema

  4. Add Test Content to Schema

  5. Make Request to new Schema with Headers

    • X-Flatten: true
    • X-Languages: de

Environment

  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: [3.0.0]

Others:


#2

Thanks for the good bug report. I will have a look.


#3

I have pushed the fix.


#4

I’m currently using the paid cloud version and I don’t see this fix, it still doesn’t work.


#5

Strange, it is the same version.


#6

@Lewitje Just made a quick test in the cloud and I cannot reproduce it.


#7

These are the headers I’m sending, and the response I’m getting.
This started happening about 1 hour ago.


#8

@Sebastian It’s working again, was something changed?


#9

I switched back to 2.X, so we can resolve your problem. Are you sure, that your casing is correct?


#10

This is what i’m sending, do you see anything weird?
(I’m limited to posting new replies because i’m a new user)


#11

No, can you check the network logs in the browser? I would like to know if the casing is the same.


#12

@Sebastian This issue is back, I couldn’t post before because I was a new member, but my updated screenshot is above.


#13

Yes, I deployed it again, cause I cannot reproduce the problem.


#14

I’m going to triple check my code, but I haven’t changed anything, I followed the docs and suddenly it doesn’t work anymore.


#15

I know, but you see that it works for me :frowning:


#16

Can you send me your bearer token and URL to the content as PM?


#17

Finally solved in a private conversation.


#18