[SOLVED] Workflow status not updating properly

I have…

  • [ ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

In a custom workflow, when I check the ‘Validate content when changed to this status.’ checkbox and save the workflow, the UI shows it still as checked. After a refresh, the checkbox is unchecked. When transitioning content to this status, the validation does not take place.

Expected behavior

The workflow status still has the checkbox checked and content is validated before transitioning to the status.

Minimal reproduction of the problem

  • Create a schema
  • Add a property which is required upon publishing
  • Create a new workflow bound to the schema created above
  • Create a new status
  • Save the workflow
  • Edit the workflow, try to check the ‘Validate content when changed to this status.’ checkbox
  • Save the workflow (successfully)
  • Refresh the browser
  • Workflow status no longer has the checkbox checked


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: ?


  • [x] Chrome (desktop, MacOS)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Url: https://cloud.squidex.io/app/werken-bij

I tested it just now and it seems it now works :man_shrugging:. This bug can be closed.

1 Like

Thx and sorry for forgetting to update the status here.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.