[SOLVED] Webhook stops working after renaming

I’m submitting a regression

  • [ x ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Webhooks stop working after I change their name.

Expected behavior

Webhooks should work after changing their name.

Minimal reproduction of the problem

  • Navigate to the Rules section
  • Click on “+ New Rule” button
  • Select Manually Triggered
  • Select Webhook
  • Fill the form and Save
  • Rename the Unnamed Rule
  • Click on the Play button to trigger webhook


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ x ] Cloud version


Checked the responses of creating and editing rules, and it seems the isEnabled becomes false after renaming the rule. Adding response for PUT request.

I can reproduce it. You can just enable the rule again.

How can I enable the rule, if I do not have any button to do that? The 2 success attempts were before adding the name.

Sorry…It seems you have to recreate the rule. It is special case of the manually triggered rule, which doesn ot have the button.

I have more than 20 projects and around 4-5 webhooks in each of them, so doing it manually will take a lot of time. Moreover, during the creation, I don’t have any option to name a webhook, which basically forces me to rename it. Also, I remember there was a toggle that allowed to enable/disable the hook, where is it?

It is just a workaround until the fix will be deployed. You can also use the API to enable the rule again.

The button is not there because it does not make that much sense for manual rules. I consider to provide the button for manual rules as well.

Can you provide some sample cURL for that. I’ve tried, but getting the following error {"message":"Entity (b27ce407-d9f0-4b02-a551-6dd1065c118c--c4f9abe0-22b6-4173-b8d6-7835c655e730) requested version 1, but found 2.","errorCode":"OBJECT_VERSION_CONFLICT","traceId":"00-f6bf837606f986478db04d57ea070f81-233e7261812e7c4a-00","type":"https://tools.ietf.org/html/rfc7231#section-6.5.10","statusCode":412}%

What exactly have you posted?

It is this endpoint: https://cloud.squidex.io/api/docs#operation/Rules_PutRule

So something like


  "isEnabled": true

Thanks, it works. Do you have any ETA for the fix?

Saturday. It is already fixed but I have a few other things in the same build that need careful testing.

1 Like

It has been solved and deployed.

This topic was automatically closed after 2 days. New replies are no longer allowed.