[SOLVED] User related placeholders are null in webhook body

I have…

  • [ ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

When I create a manual Rule and add the placeholders related to the user in the body, they come up to be null in the request.

Expected behavior

It should put the real values of the user in the request body when the rule is triggered.

Minimal reproduction of the problem

Create a new Manually triggered webhook on an application and put the following contents:




Execute the rule and check the logs for the request details. There, you would see that the APP_ID and APP_NAME and the date are set correctly, but the user-related data is equal to null. Just like this:



  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: [VERSION]


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


Thank, this is only related to manual triggers. It show work for normal triggers

Solved, but not deployed yet.

That was quick! :slight_smile: Thanks! Hope will be deployed soon.

Hi @Sebastian. Hope you are well. Is there any status update on this fix? Any idea when approximately it would be deployed?

I hope tomorrow…but no guarantee.

1 Like