[SOLVED] User mentioned rule does not trigger when comment is more than 255 characters

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

I created a User mentioned rule that triggers a webhook. When I mention a user within a comment on a Content item, and the comment is more than 255 characters (including the mentioned email address), the rule does not trigger and the logs on the rule are empty, even though the comment is stored.

Expected behavior

The rule should be triggered or the comment should be restricted to max 255 characters.

Minimal reproduction of the problem

  • Add a new User mentioned rule with a webhook action and without any conditions
  • Create a content item
  • Publish the content item
  • Add a comment on the content item and mention someone by email address, that is longer than 255 characters
  • Wait for the rule to trigger


App Name: -

  • [x ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: 6.14.0 (I am on an older version)


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [x] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


This also happens in version 7.5.0, which I have deployed for another application.

How have you found that it is exactly 255 characters? :wink:

It is correct and the issue is actually this regex (https://github.com/Squidex/squidex/blob/master/backend/src/Squidex.Domain.Apps.Entities/Comments/DomainObject/CommentsCommandMiddleware.cs#L17) … I am just impressed :wink:

@Sebastian Just trial and error :sweat_smile:.

So I suppose this is actually a bug? Is there any particular reason it is limited by 255 characters?

Actually I do not understand this part of the regex. I think I copied it somewhere…

It has been solved. I will post the docker tag here, when the build is done.

It is docker tag dev-7605

Great, thank you for the bug fix.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.