[SOLVED] UI issue with contents filter

On Squidex Docker 6.9.0 and 6.8.0 I noticed that backups cannot be restored without loosing quite a lot of content.

I was going from Squidex 4.6.0 to Squidex 7 and restored all data on 7 with success, but Squidex 7 has some bugs on the interface like the Filters view, which I use quite a lot and thats not possible in 7.


So I did the following:

  • Installed Squidex 6.8.0 and restored (content missing)
  • Installed Squidex 6.9.0 and restored (content missing)

Both installs I did twice. One time with the backup from 4.6.0 and one with the one from 7.

Strangly I noticed that the Schemas where content missing are there but are not shown inside the content area…

Maybe there is a trick?

1 Like

I have just pushed a new fix for the filters. It is was only a few lines of code. I will give you the docker tag, as soon as it is done. If it builds it will be dev-7007 tag: https://github.com/Squidex/squidex/runs/7346217637

But please note, that 7.0 is still in pre-release.

To understand the problems with 6.8.0 and 6.9.0 I have to understand what you have actually done. Have you used a normal backup with the restore endpoint or have you migrated an old database?

Can you provide the backup? If yes, just send me a PM and some notes, what I should test.

I just used the backup feature over the GUI without any database migration.

Looking forward to test the dev-7007.

If you provide me the backup, I can have a look. Otherwise, I have to close this bug report. I just cannot do anything then.

But the UI problem is fixed.

Thank you but sadly I cannot share that backup.
I tried dev-7007 but I cannot login as it is loading forever without any login screen appearing.
I will wait for the next version.

Closed, as the backup problem cannot be reproduced. The filtering issue has been solved.