[SOLVED] Textindexer5 Lat/Lng mixed up

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

A bulk write operation resulted in one or more errors. WriteErrors: [ { Category : “Uncategorized”, Code : 16755, Message : “Can’t extract geo keys: { _id: “983a4493-90ab-40f5-bf59-12b206f84443”, DocId: “8d4adfc0-d975-4925-93ef-42b38258a4be–f648ed64-d89b-468b-a6ee-c3b17dc56b35_1”, _ci: “f648ed64-d89b-468b-a6ee-c3b17dc56b35”, _ai: “8d4adfc0-d975-4925-93ef-42b38258a4be”, _si: “0e6faf66-2664-4246-8e2d-44944167e21d”, fa: true, fp: true, gf: “LatLng.iv”, go: { type: “Point”, coordinates: [ 10.28333, -109.21667 ] } } longitude/latitude is out of bounds, lng: 10.2833 lat: -109.217” } ].

Expected behavior

Lat/Lng should be inserted in the correct order. In the error Message you can see LatLng with -109 in Lng, but following -109 was used in the lat field

Minimal reproduction of the problem

Use the Lat/Lng for Ile de Clipperton Lat=10.28333 lng=-109.21667 ]


App Name:

  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: latest


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


How have you created this geocoordinate? Because the code looks actually correct: https://github.com/Squidex/squidex/blob/master/backend/src/Squidex.Domain.Apps.Core.Model/Contents/GeoJsonValue.cs

I inserted the GeoCoordinate with the API and the coordinate looks good in the Web Frontend. I think the indexer code mixes lat/lng when creating the index in mongodb. I get the error in the worker while the index is created.

Here a screenshot how the failing object looks in mongodb

Are you sure, that you are running latest? I cannot reproduce it.

Shame on me, I had the error since 3 weeks and when the image was running latest which was 7.1.0

Now I see there is a new release 7.2.0 which fixes the swapped geo lat/lng

I just pulled latest again and I see if the textindexer works now

Sorry, I wanted to test myself the past weeks and did not look again when posting now

I actually do not remember that I have fixed it, but good that it works for you :wink: