[SOLVED] Squidex Login via Github Broken


#1

I have…

  • [ ] Checked the logs and have provided uploaded a log file and provided a link because I found something suspicious there.

I’m submitting a…

  • [X] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Attemping to login to Squidex via the Github integration redirects to a localhost:5000 url.

Expected behavior

Logging in should correctly redirect to the appropriate squidex.io endpoint.

Minimal reproduction of the problem

Attempt to login.

Environment

  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [X] Cloud version

Version: [VERSION]

Browser:

  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Others:


#2

I don’t get what you want me to say. I need more details.


#3

GitHub Login is broken on cloud.squidex.io.
Steps to reproduce:

  1. Go to cloud.squidex.io
  2. Click Login to Squidex button
  3. Click Login with GitHub button
    As a result you will see a redirect to localhost:

Login with Google and Login with Microsoft work fine.


#4

Sorry, have not seen the checkbox which indicates that it is related to Cloud.


#5

Thank you very much, it is solved.


#6