[SOLVED] Squidex frontend shows dates as UTF8 characters

I have…

  • [x] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Date in some Apps comes up correctly on detailed edit view but displays incorrectly in the bulk edit view on the squidex CMS. The API seems unaffected. Probably some UTF8 encoding issue or something. The data seems correct on the details view. The data was imported into the 1336 App if that is relevant.

Expected behavior

Minimal reproduction of the problem


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: [VERSION]


  • [ ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


I do not have this problem. Which locale do you use?

It is not some random string, it is AM / PM in Chinese: https://github.com/date-fns/date-fns/blob/e0fc48a2132c90fa0b5b0f4885d71f940e63a3a9/src/locale/zh-CN/snapshot.md

@kmaid are you in china by any chance?

There is an issue with the language selection, will be fixed soon.

Solved and deployed.

This topic was automatically closed after 2 days. New replies are no longer allowed.