[SOLVED] Rules, Settings, API links not working


#1

I’m submitting a…

[ ] Regression (a behavior that stopped working in a new release)
[x ] Bug report
[ ] Performance issue
[ ] Documentation issue or request

Current behavior

I click on either of the links but nothing happens. I updated Squidex 7 days ago with what was the latest docker image at the time.

Expected behavior

Links should work.

Minimal reproduction of the problem

  1. Go to your app.
  2. Click on any of the 3 links mentioned above.

Environment

  • [ ] Self hosted with version docker
  • [ ] Self hosted with IIS
  • [x ] Self hosted with other version
  • [ ] Cloud version

Browser:

  • [x ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Others:

I’m running Squidex in AKS. Prior versions did not have this behavior.


#2

Do you see an error in Chrome? The latest Docker version is the same as the cloud version (more or less).


#3

Yeah, was gonna post but the log was humongous…
It was some js error… something about a chunk…
Will paste relevant parts of log tomorrow…


#4

Yes, the angular uses lazy loading. Every menu item on the left is a custom file. It seems that it fails to load a particular chunk.


#5

Hmm, I should have saved those logs. :confused:
Need help troubleshooting this one? Let me know.


#6

I havent had the time yet to reproduce it but I want to deploy the latest version to the cloud today and will ensure that the production build works.


#7

I checked the latest versions and it looks good. I had a bug in the build process between, but it was after you created the post and it even happened for the apps overview.


#8

After pulling latest squidex today App API / Swagger gives me a 404 I think it was. Other pages seem to work fine.


#9

Okay, I will check it.


#10

It is a bug with the permission system. Great that you found it and than you again for all your support and patience.


#11

No problem, great you found it!


#12

I fixed it in the latest dev version


#13

Sorry, had to restart the build and have not noticed it, will be ready in 20 min


#14

I deployed the newest version and could not reproduce the issue. I treat this issue as solved now.


#15