[SOLVED] Restoring backup shuts owner out of settings


#1

I’m submitting a…

[ ] Regression (a behavior that stopped working in a new release)
[X] Bug report
[ ] Performance issue
[ ] Documentation issue or request

Current behavior

Restore a backup and only Pattern is visible in settings for “Owner.”

Expected behavior

All settings should be visible but only the “Patterns” are available.

Minimal reproduction of the problem

Restore a backup from a previous version (maybe?) and go to the new app’s settings.

Environment

  • [X] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Browser:

  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Others:


#2

I have fixed it. As a workaround you can go the Users overview and assign the following role to this user:

squidex.apps.<YOUR-APP-NAME>.*


#3

Hmm. Clicking ‘Save’ doesn’t do anything when I’m in my user profile. I can see it, no errors, and no network requests are made. :thinking:


#4

Which version do you use? I just tested it and it works.


#5

You are reporting so many strange issues, perhaps we should make a skype session.


#6