[SOLVED] Required fields are nullable in the OpenAPI specification

Fields that are marked as required in a schema definition still have nullable: true in the OpenAPI specification. This makes using them awkward in clients that use the specification to generate stubs. I understand that a required value currently does not have to be present on objects that were created before the field was required, but that feels like error-prone behavior to me nonetheless.

Are you talking about the general API or the content API?

The content API (the one used to query content in clients).

1 Like

it is solved, but not deployed yet.

Thank you very much for the bug report.

Glad to hear that! Do you have any estimate on when this is going to be available in the Squidex Docker image?

You can try the current dev tag.

I tried dev-4508 and there’s still nullable: true on all my fields. Is this really the tag you meant?

e.g. 4750 should work…

Interesting, 4508 seems to be the most recent one on docker hub. Is there any other source for Squidex images I’m not aware of?

Yes, I see why. The others are release/4.x releases and therefore not pushed to docker yet, the 5.0 is not ready yet.

Got it. Do I need to build from source then?

I tested it with the newly released Docker images and it looks good. Thanks!

1 Like