[SOLVED] Problem with new editor locally

I have problem with new editor, in squidex cloud everything works. But locally when I download the code from git and run it locally on windows or in docker in a chrome browser in list wiith field text editor i see this

and when I open the content then the editor looks empty.If I add another image only then the previous one appears.

  • Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • Regression (a behavior that stopped working in a new release)
  • Bug report
  • Performance issue
  • Documentation issue or request

Current behavior

Expected behavior

Minimal reproduction of the problem

Add content and string field with richtext editor. Add an image in this field. Refresh the page. The image disappears, it remains only in the markup preview.


  • Self hosted with docker
  • [+ ] Self hosted with IIS
  • Self hosted with other version
  • Cloud version

Version: [VERSION]


  • [+ ] Chrome (desktop)
  • Chrome (Android)
  • Chrome (iOS)
  • Firefox
  • Safari (desktop)
  • Safari (iOS)
  • IE
  • Edge


Do you see an error in the chrome logs or so? Perhaps I just fucked up something that I have not deployed yet.

I checked it again and I cannot reproduce. Perhaps I have somehow fixed it without realizing it.

I downloaded the latest changes from the master branch and unfortunately I still have the problem.After adding a photo and refreshing or re-entering the article, the photo does not display/render.In the console I have this error but I think it is not the cause.
ezgif.com-optimize (2)
“global-error-handler.ts:31 Error: NG0100: ExpressionChangedAfterItHasBeenCheckedError: Expression has changed after it was checked. Previous value: ‘false’. Current value: ‘true’. Expression location: _InternalAreaComponent component. Find more at Angular
at throwErrorIfNoChangesMode (core.mjs:11842:11)
at bindingUpdated (core.mjs:16178:17)
at Module.ɵɵproperty (core.mjs:17467:9)
at InternalAreaComponent_nav_0_Template (internal-area.component.html:3:19)
at executeTemplate (core.mjs:12159:9)
at refreshView (core.mjs:13392:13)
at detectChangesInView (core.mjs:13617:9)
at detectChangesInViewIfAttached (core.mjs:13580:5)
at detectChangesInEmbeddedViews (core.mjs:13537:13)
at refreshView (core.mjs:13416:9)
at detectChangesInView (core.mjs:13617:9)
at detectChangesInViewIfAttached (core.mjs:13580:5)
at detectChangesInComponent (core.mjs:13569:5)
at detectChangesInChildComponents (core.mjs:13630:9)
at refreshView (core.mjs:13442:13)”

In the 7.9.0 release, I do not have this problem.

Yes, I can reproduce it now. I have always tested it in my local editor demo, where I built the editor in general. But it only happens in Squidex. So it is either a build problem or the integration with angular. 7.9.0 is still angular 16, so it could have happened in the migration to 17.

It is super hard to debug so far.

EDIT: I found it: It is a bug in the editor library (remirror): usePortals is buggy · Issue #2226 · remirror/remirror · GitHub

1 Like

I have fixed it with https://www.npmjs.com/package/patch-package … This was a hell of debugging.