[SOLVED] Possible cloud editor regression / components disappearing and reappearing in editor


One of my co-workers noticed, starting about two days ago, that components that exist within a components-type field will sometimes disappear and then can be made to reappear by scrolling.

Here is a link to a video demonstrating the issue:

In the above video we have a schema called “topic” which includes a components field called “sections”. A set of “section” components exists within the field, but sometimes, when the section components are collapsed, remaining components disappear. They can be made to reappear by scrolling down and up.

Perhaps this is a regression from the recent cloud deployment?

Please let me know if I can be of further assistance in resolving the issue.


1 Like

yes, i am having the same problem.

Thanks, I have (by accident) changed the threshold to turn on virtual scrolling to 5 elements. I guess this is why it happens. But the question is still: Why is the virtual scrolling behaving so weird. I am going to change it back to the previous value and the investigate the issue.

Solved and deployed.

Thanks for the fix, Sebastian!

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.

@blistick I have reopened it, but I cannot reproduce it.

Okay, I am wrong, I can reproduce it.

Glad to hear that. Let me know when you’re ready for me to validate the fix.

The problem was due to the virtualization library. Because some users have so many array items we cannot load them all. Instead we load them on demand while scrolling. This concept is called virtualization. I have a new implementation with another library in progress and hope to deploy it this Friday.

Thanks for the update, Sebastian. Looking forward to the fix.

Hi Sebastian. Just wondering, has the version with the new virtualization library been deployed to cloud Squidex?

Yes, it has been deployed. Does it not work for you?

I’ll have my team members check and let you know. Thanks.

1 Like