[SOLVED] Ordering of fields in lists not updated

I have…

  • [x] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Managing the columns/fields that are visible on the list view of a schema has some bugs:

  • you can’t reorder the fields properly, because they jump back to their initial position (link to video)
  • the initial order of the fields is not in line with the actual fields order in the content list view when first entering the view

Expected behavior

  • fields can be reordered and stay in their new position
  • fields have the correct position when entering the UI tab of the schema settings page

Minimal reproduction of the problem

  • navigate to: https://cloud.squidex.io/app/<appId>/schemas/<schemaId>?tab=ui
  • drag a field to a different position (on the left side)
  • release the field handle
  • field jumps back to its old position
  • click save
  • navigate to content list view of the schema, order of fields/columns has changed
  • navigate back to schema settings, ui tab
  • fields are still shown in wrong order


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version


  • [x] Chrome (desktop, MacOS)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Thanks, I will have a look

1 Like

It has been fixed and deployed. It was only a minor UI problem (one-liner).

1 Like

I checked it and indeed it works. Thanks! :raised_hands:

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.