[SOLVED] ODataQuery year() Not Functioning

I have…

  • [X] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [X] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

I realize you are switching over to GraphQL, but since the current .Net API doesn’t work with that, I figured this might be worth fixing.

When doing a filter of year(data/datetime/iv) eq 2020, Squidex sends back a 500. I know it’s not an invalid query because I have gotten that error message before and that is not the one I got this time. I get a 400 on invalid query.

Expected behavior

This query should allow you to compare years of datetimes.


  • [ ] Self hosted with docker
  • [X] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version


  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


but we have to distinguish between the bug (500 vs 400) and the feature (year)

Year was never implemented, but I can add it as a feature request.

I have solved the 500.

If you want: Create a feature request with the odata operators you would like to see.

Sounds good. Thanks for the help as always.