[SOLVED] Not able to change the status of content from published status, if the content is being referred in other schema

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [X] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

if the content of schema A is being referred in content of schema B and all contents are in published state, then if we trying to modify the content of schema A by changing the status as amendment(using custom workflow), we are not able to do it and getting pop up of error message ‘Content is referenced by another content and cannot be deleted’. This error message seems legit if we try to delete the content but we are actually trying to modify the content.


  • [X] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: [5.6.0]


  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Can you not confirm the popup?

The error message seems to be wrong, but the feature is as designed.

Or perhaps it is the same as the other error with the validation message, I will test it.

1 Like

I am just getting the error message in red pop up ‘Content is referenced by another content and cannot be deleted ’ while trying to change the status.

if you are talking about the confirmation popup that we usually get when we delete the content, i am not getting that confirmation popup for changing the status.

1 Like

I have fixed it and the build is in the pipeline. The build is not so stable at the moment, due to issues with karma (node test runner).

But when it is done, the tag is dev-5894

1 Like

Thanks Sebastian for the quick fix.

It contains both fixes.

1 Like

Thank you so much Sebastian for both fixes.

1 Like

Does the fix work for you?

is it deployed in cloud? I haven’t verfied yet by taking the pull of tag.

Not yet, I thought you have installed Squidex yourself.

Hi Sebastian,

I have verified the issue from my side. the bug is still there. if the referenced content is in published status and then changing the status to draft not happening.
I am still getting the error Content is referenced by another content and cannot be deleted or unpublished, but when I do refresh the page then only it is changing the status to the draft.

before your fix, it was not changing at all even if you do refresh the page.

It is in the pipeline: dev-5897


This topic was automatically closed after 2 days. New replies are no longer allowed.