[SOLVED] New schema -> 404

After creating a new schema in Cloud, it appears, then disapears from the menus (schemas, content).

Sometimes after page reload the schema reappears, but leads to 404.

Then, when it appears, and after creating content, the content disapears.

More, it cant be edited, the UI return some errors :

Failed to make the update. Another user has made a change. Please reload.
Generic error

In the client side, multiple types behaviours :

Randomly works
SquidexException: The app, schema or entity does not exist
SquidexException: Squidex Request failed: {“message”:“Query $filter clause not valid.”,“details”:[“Could not find a property named ‘Slug’ on type ‘Squidex.Section’.”],“statusCode”:400}

All this more than 30/40 minutes after schema creation.

Any help ?


I’m submitting a…

[ ] Regression (a behavior that stopped working in a new release)
[x] Bug report
[ ] Performance issue
[ ] Documentation issue or request

Current behavior

Expected behavior

Minimal reproduction of the problem


  • [ ] Self hosted with version docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version


  • [ x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


Sorry, It was a clustering issue. It is not really solved yet, but I will investigate it. When this happens the cluster members are still in the load balancer but not connected anymore. Then you get this kind of inconsistencies. I am working on it to solve it. It has happened several 2 times in the last days but it is the first time ever that it happened.

I found the issue, the node was not shutting down properly: https://github.com/Squidex/squidex/commit/e3c07fb9b88d5664495c04ea6d5a54041e6de8d0#diff-90a927342c0123773f5b08d6d44c6ee9

Very stupid error when I migrated to IHostedService interface.