[SOLVED] Multilanguage rich text editor not saving when using clipboard

I have…

  • [ ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

When switching language in a content item inside Squidex and typing something in a mutli language rich text field it doesn’t save the new content.

Expected behavior

Minimal reproduction of the problem

  • I have some content already in the English rich text field
  • I switch the language to Dutch
  • Add some new content to the rich text field
  • Click save
  • Reload the page
  • The content in the Dutch field isn’t saved

Environment

  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: [VERSION]

Browser:

  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Others:

Thank you, I will have a look.

Sorry, I cannot reproduce it

I made a recording of how I get the issue, I hope this explains it better?

Not sure if I understand, perhaps it is something with the clipboard?

Ah yes it does seem to be that, if I clear both languages and type something it saves.
Thank you!

But anyway, it is a bug…

I have solved it, but NOT deployed it yet.