[SOLVED] Missing line breaks in the new text editor

I have…

I’m submitting a…

  • [x] Regression (a behavior that stopped working in a new release)

In the new editor I’ve noticed it seems to like to hide my line breaks between paragraphs.

For example, when editing I see this…

But if I save, then re-load the editor, it looks like this:

I’ll probably just switch back to the old editor for now, but is this something that is likely to be tweaked?


I should add, this is a Markdown field.

Thx. I will fix it today.

It is fixed but you might need a hard refresh to reload the editor.

Thanks, can confirm it is fixed :slight_smile:

I just wonder if it is fixed properly.

Let me explain:

If you create a normal new line in the text editor, it creates a new paragraph, e.g.


This would be 2 paragraphs in prosemirror. The problem was that the paragraphs have no margin-bottom, so it was really difficult to understand that. So you have used a new line, because you are used to markdown, but this is leaking the markdown syntax into the editor. So the correct behavior would be to just fix the styling.

I think I see what you’re saying.

So long as the line breaks look “right” in the editor (there’s a nice gap between lines) I think that would be fine.

I definitely have a lot of learned behaviour/habits from editing the markdown.

Sorry to hijack this ticket, but one thing I’ve found using cloud-hosted Squidex, is if I try to revert to the old markdown editor using this link:

I don’t seem to be able to use the “add content” button, to embed references to other items.

My workaround is to manually locate the content item and manually reference it, but I wonder if there’s any way to use the old editor and still be able to add content that way?

It should work, perhaps it is a bug…I will have a look.

1 Like

Solved and deployed, including the problem with the old markdown editor.

This topic was automatically closed after 2 days. New replies are no longer allowed.