[SOLVED] Login to Squidex in original window

Hi @Sebastian,

I’m trying to modify login journey of my Squidex app.

**Following is the Current login journey: **

  1. User clicks on “Login to Squidex” (green button) on Squidex home page as attached “Step-1.png”,
  2. A login popup opens that has username and password entry fields with Login as attached “Step-2.png”.
  3. When user enters credentials and click login, a different popup with “Login to Squidex” is displayed that asks user to sign-in again as attached “Step-3.png”.
  4. On clicking “Login to Squidex” button, login occurs within the popup window as attached “Step-4.png”.
  5. User than has to close the popup window and refresh the original window to sign in.

Desired login journey:

  • User should be able to sign in on the original window.
  • Popup window should open but login should be carried out in original window.

Please let me know how I may achieve above/desired login journey.

I have never seen the extra popup. Which operation system and browser do you use?

I’m using Windows 11; the popup is found in Chrome and Edge browsers.
I’m good with popup, but on clicking “Login to Squidex” button (of Step 3 of above image), login should occur in the original window.
(Currently, login occurs within the popup window as displayed in “Step 4 of above image”.)

If you want to have a redirect instead you can use the following setting:

To main reason for the popup is performance, because it is relatively slow to load the SPA.

I’m fine with popup but I need to know why the home page opens in popup after login.

Is there any setting/code available to change target window on which to open home page after login?

I will try again, but I cannot reproduce it. Usually the popup should just close itself. Perhaps this is some error in the Chrome console.

This is with "allowPasswordAuth": false so that it automatically forwards to our custom login provider (see step 2); could well just be an issue on our side but any insight from yourself would as always be greatly appreciated!

Sounds like a redirect issue that is independent from your settings.

Usually the redirect goes to /client-callbackup-popup.html. This is just a super simple and basically empty html file:

The script is responsible to send the authentication info back to the host frame and to close the popup.

Perhaps the redirect info gets lost or you have configured a static redirect URL?

I think it is a bug, because the returnUrl gets lost somewhere. I will provide a fix asap.

1 Like

It was exactly that: https://github.com/Squidex/squidex/commit/7fa842c2b820090306cdee67827557df0c00d3eb

Most people use external authentication providers with redirect option so that squidex redirects automatically without the extra click. Therefore nobody noticed it yet.

1 Like

Hi @Sebastian,

Is commit 7fa842c actual fix for redirect Url getting lost? or will there be another fix for redirect Url?

I’m unable to upgrade my app’s Squidex version right now, so is there any other option to try redirect Url fix without upgrading?

You have to update to dockers tag dev-7562

This topic was automatically closed after 2 days. New replies are no longer allowed.

Would this be able to be done as a patch for 7.2.0 or will you be aiming for a 7.6.2 or 7.7.0 release soon?

If it is really needed…yes. This is what you are paying for :wink: