[Solved] Jwt expired when trying to log in on self-hosted squidex


#1

I have…

  • [x] Checked the logs and have provided the logs if I found something suspicious there

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request
  • [x] Still not sure whether this is a bug

Current behavior

When I’m trying to log in on our staging Squidex environment, after being prompted for the login and password, the login window closes and an error is written in the console stating that the ‘exp’ is in the past. This error started this morning and is affecting all users equally from different geographical locations.

(Stack trace of JS error from Chrome)

JoseUtil._validateJwt: exp is in the past 1561988617
e	@	app.js?c240db6…:2
e	@	app.js?c240db6…:2
e	@	app.js?c240db6…:2
e	@	app.js?c240db6…:2
(anonymous)	@	app.js?c240db6…:2
r.invoke	@	shims.js?c240db6…:2
onInvoke	@	app.js?c240db6…:2
r.invoke	@	shims.js?c240db6…:2
n.run	@	shims.js?c240db6…:2
(anonymous)	@	shims.js?c240db6…:2
r.invokeTask	@	shims.js?c240db6…:2
onInvokeTask	@	app.js?c240db6…:2
r.invokeTask	@	shims.js?c240db6…:2
n.runTask	@	shims.js?c240db6…:2
b	@	shims.js?c240db6…:2
Promise.then (async)		
y	@	shims.js?c240db6…:2
r.scheduleTask	@	shims.js?c240db6…:2
onScheduleTask	@	shims.js?c240db6…:2
r.scheduleTask	@	shims.js?c240db6…:2
n.scheduleTask	@	shims.js?c240db6…:2
n.scheduleMicroTask	@	shims.js?c240db6…:2
I	@	shims.js?c240db6…:2
D	@	shims.js?c240db6…:2
(anonymous)	@	shims.js?c240db6…:2
e	@	app.js?c240db6…:2
e	@	app.js?c240db6…:2
notifyOpener	@	/scripts/oidc-client.min.js:47
callback	@	/scripts/oidc-client.min.js:47
_signinCallback	@	/scripts/oidc-client.min.js:47
signinPopupCallback	@	/scripts/oidc-client.min.js:47
(anonymous)	@	/client-callback-popup:12

Expected behavior

Being able to log in

Minimal reproduction of the problem

Environment

  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: v2.2.0

Browser:

  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [x] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [x] Edge

Others:
I checked the server logs and there are no warnings or errors on the API side. I can provide server logs if required. I have also cleared the browsers cache multiple times

Screenshot attachment:


#2

I have only seen it when the server time was not correct.


#3

Hey Sebastian. Thanks for your response; that was it. I forgot to check the most basic thing which was the clock itself. The KVM2 VM on which kubernetes is running suffers from clock drift and it was out of sync by 16 minutes. I really should learn to troubleshoot the basic things before immediately trying to trouble shoot the quantum effects of electrons in a processor.

Thanks again. Considered closed.