[SOLVED] Issue with 7.13 upgrade

I have…

  • Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • Regression (a behavior that stopped working in a new release)
  • Bug report
  • Performance issue
  • Documentation issue or request

Current behavior

Won’t load assets

Expected behavior

Loading the assets.

Minimal reproduction of the problem

I’m guessing use the GridFS asset plugin.


  • Self hosted with docker
  • Self hosted with IIS
  • Self hosted with other version
  • Cloud version

Version: 7.13


  • Chrome (desktop)
  • Chrome (Android)
  • Chrome (iOS)
  • Firefox
  • Safari (desktop)
  • Safari (iOS)
  • IE
  • Edge

Here is the error when I try and access the assets:

Actually it looks like your data is corrupt. This means that there is no file hash for at least one of your assets.

You could either…

  1. Just create a dummy file hash with a mongo update.
  2. Rebuild all assets with the following environment variable REBUILD__ASSETS=true

The file hash is only needed for avoiding the upload of duplicate assets, so I recommend to go for the first approach.

1 Like

So this was with Rebuild Assets on. I took my data from production v4 and did an upgrade to test – I’ll try a full migration again.

Interesting. I can also revert that setting, not a big deal.

1 Like

You can use docker tag dev-7882

1 Like

Fantastic – that fixes the issue with those assets! Thank you, Sebastian!

1 Like