[SOLVED] IIS Hosted: could not create new custom user


#1

Hi, have issue with creating new custom user from administration panel

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [X ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

  1. Open /app/administration/users/new
  2. Enter all fields
  3. Push Save button
  4. Nothing happens - request does not even sent to api

Expected behavior

Expect that user will be created

Environment

  • [ ] Self hosted with docker
  • [X ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: [VERSION]
sources of 6 days ago commit: 8326a0143080f5a6e8cc7ee3778e5d4fe3fe36f9

Browser:

  • [ X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Others:


#2

Thank you, I will have a look.


#3

I think the error details do not show up properly, but if you have a look to the Browser network tab you might find the issue.

Edit: You said that it is not doing an api request. Are you sure? Can you check your browser logs? have you set the password?


#4

I can reproduce it in the next branch and have fixed it there.


#5

Hi Sebastian,

could you please backport this bugfix into the current branch?

This seriously affects the main functionality of the system in a negative way.


#6

I am not sure if the problem exists in this way in the main branch, it works for me in the cloud.

A few days ago I accidentally pushes next to master, so you might be on the next branch already.


#7

The problem definitely exists in squidex/squidex:latest Docker image which has been built 6 hours ago.

It would be great if CI image build process’ve got triggered for the bugfix commit :wink:


#8

Can you show me the JSON result when you query all users?

It might have happened that latest is also the next stuff.


#9

Even in case of the latest == next, the squidex/squidex:next still doesn’t contain the fix :slight_smile:
I am ready to switch from latest to next, the only thing needed is that CI Docker build that updates DockerHub images :slight_smile:


#10

Hi Sebastian,
master contain this issue,
The fix you’ve submitted into next branch helped me for master branch based sources as well.


#11

Yes, I will…

  • Prepare a new tag for next (3.0.0-beta3)
  • Fix it in master as well.

#12

Btw: I have fixed it…


#13