[SOLVED] How to use format WEBP etc

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [x] Documentation issue or request

Current behavior

If i try to open image with set format=WEBP as is in docs https://cloud.squidex.io/api/docs#operation/AssetContent_GetAssetContent

For example:

If i do not set format parameter it seems like it returns same image (same size same content type).

WEBP vs non-set

It seems like it still returns to its original format (jpg). Is it expected? Is there a way to get WEBP format from non webp format?

Expected behavior

Convert image to set format.


App Name: test-test-1234

  • [X] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [X] Cloud version

Version: last stable


  • [X] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Sounds like a bug. I will get it fixed this week.

Your usage is correct.

1 Like

Solved, but not deployed yet. Have also added an api test for that.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.