[SOLVED] Global Search displays [object Object] after clicking a search result

I have…

  • [x ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [ x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

When performing a search in the header bar within an application, results are displayed. But when clicking on a result the search box is filled with “[object Object]” and nothing happens.

Expected behavior

When clicking the result I would expect to be redirected to the relevant item.

Minimal reproduction of the problem

We have migrated from v4.1.0 to v5.4.0 and the search feature was not available in our old version so do not know if there is anything we need to do.
We have tried resetting the TextIndexer5 consumer.


  • [ ] Self hosted with docker
  • [ x] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: v5.4.0


  • [x ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

When performing the search I can see the request completes and returns JSON that looks valid.

This is already fixed in 5.5.

Thanks for the info. I noted that there is no download for the binaries for v5.5. Is there a reason for this? Is v5.5. a beta? It does not show as the “latest release” in github.

Thats true, but it is in the changelog and docker. Perhaps a issue with the build…

This topic was automatically closed after 2 days. New replies are no longer allowed.