[SOLVED] FileHash property not present in Assets


#1

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [X] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

I have just generated the C# client from the swagger.json configuration file (https://legacy.squidex.io/api/swagger/v1/swagger.json) and I found out that there is a new required property for my assetsDto named “fileHash”.
When I tried to retrieve from API all my Assets I got a deserializaion exception because the field fileHash is not present in the json response retrieved from Squidex.
I also tried to upload a new image and, as I expected, when I asked the assets from API, the new one has correctly the fileHash property, while the old ones not.

Expected behavior

A modification on the AssetDto swagger.json definition should be backward compatible with the old assets.

Environment

  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [X] Cloud version

#2

Thank you, you are correct, the file hash should not be required as old files will not have a hash.

I have fixed it, but not uploaded a new version to the cloud.


#3

Thank you Sebastian.
Could you please write here when you will deploy the new version on Cloud ?

Moreover, is not possible to add the hash property to the old files ? In this way I can be sure that all my assets have the hash.


#4

Yes, I will.

It would be a very costly operation to download all assets and then calculate the hash, therefore i have not implemented such a migration.


#5

#6

Hi, I deployed a new version.