[SOLVED] Fallback languages resulting in null value when queried

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [X ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

Multi language content (images, text) shows null value for optional languages.

Expected behavior

Should display fallback language content

Minimal reproduction of the problem


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ X] Cloud version

Version: 4.0


  • [X ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

Has there been a change in the behavior or the API for fallback languages and how to access the assets via the API?

1 Like

There has been made small modifications, but the fallback languages work over headers and you won’t see it in the GraphQL UI by default.

I’m seeing a similar problem, but it only seems to affect entities modified since the beginning of this year roughly.

@Sebastian I can send you full curl requests including auth in DM, if you wish. One request would be for RU and the other for BE for which we defined RU as the fallback language. When comparing the results one can easily see the issue.

Our users are starting to cancel their subscriptions because of this. :sweat: It seems the issue started to pop up a few days ago. Any news here? @Sebastian

I will have a look, but I cannot always react immediately, especially if it is not a bug that has just popped up and can be rolled back.

There has been one change: Empty strings are valid values now. Before the latest change a few weeks ago, empty strings were replaced with fallback values. This was kind of odd, because empty strings are valid values in many cases.

1 Like

I understand the problem now. A few days ago a piece of code was removed that was eliminating “null” values from content data, when it was saved. It was causing all kind of issues. But the fallback system only checks if a value exists, not if it is is null.

Therefore the fallback handling does not work for new content items. I will provide a fix soon.


Many thanks! Didn’t want to sound pushy or anything, we just got quite a few user requests and I was worrying that there would be many more over the weekend. :sweat_smile:

Just checked, looks like it’s working again. Many thanks, once more! :pray:

I have not done anything yet.

Oh no, my bad. I checked the wrong request. :man_facepalming: Yes, I can confirm the problem still persists.

@Sebastian I see this has been marked as solved. However the issue still persists on our end (see the curls I’ve send you a few days ago). Any idea why?

I am usually mark the issues as solved when I have fixed the bug and then I add a comment when it has been deployed. I will do it today in around 2-3 hours. I would like to monitor the deployment, therefore I cannot do it earlier.

1 Like

Ah, sounds good, thanks! Looking forward to it! :slight_smile:

It has been deployed now …

1 Like

I checked and it works like a charm, many thanks! :smiley:

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.