[SOLVED] Exceptions while creating app with Client Library

I have…

  • [x] Checked the logs and have provided uploaded a log file and provided a link because I found something suspicious there.

I’m submitting a…

  • [x] Regression (a behavior that stopped working in a new release)
  • [ ] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

We use the Squidex Client Library to check if an app exist and if not to create an app with the admin client. Then set the admin user as contributor to this app.
Everything worked fine with Squidex version 3.2.2.
Above this version we always get an exception during our ‘Squidex Initialization’ Code.

Expected behavior

Create app, assign admin user as contributor to this app, after that init schema and test data.

Minimal reproduction of the problem

Use Squidex Client (3.15.0) and following commands:

var apps = await AppsClient.GetAppsAsync();
// if not extist -> create one

// Check if admin is owner
var contributors = await AppsClient.GetContributorsAsync(AppName);
(Here we got an exception) if I skip this check, i get an exception with following:
await AppsClient.PostContributorAsync(AppName, assignContributorDto);

The exception:

It seems, that the creation of the app works. Because if I rin our code again, an exception with “App already exists” is shown. But I can’t see our app in Squidex, because the admin user is not a contributor.

I also checked the logs of Squidex with following Error:

We use the current mongo version 3.6.15


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version

Version: 3.5.0
Squidex Client Library: 3.15.0


  • [ ] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge


Could that be a problem/bug with the mongo db and the admin client?
Thank you very much for your help.

The admin client is not the same as the admin user. it is therefore the default behavior that you do not see the app.

Can you try out the dev version, I will release a 4.0 soon anyway. Or a short sample app to reproduce it would be great as well.

Hi, Yes I know that the admin client is not the same as the admin user.
We use the admin client, to create an app from scratch. (Empty Squidex)
This worked very well until 3.2.2.
I have tried different versions 3.3.0, to 4.0beta and also your latest dev version.

Maybe I can provide a part from our init code later.

Thanks so far.

1 Like

Can you also provide the logs? A 500er error is a server error and probably not an issue with the client library.

How can I add the log file to this post?

You could just upload it to drive or dropbox or so and send me a link?

I have pushed a fix.

Hi. You mean the client library version 3.16.0?
I have just tested it, but I have still the same problem/exception for ‘GetContributorsAsync()’

No, to Squidex itself.