[SOLVED] Error executing document when you create a schema called content

I have…

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

I created a new schema called content.

When I published the new schema GraphQL queries stopped working.

Attempting to execute any GraphQL queries resulted in an error…

Error executing document.

Once I unpublished the schema things seemed to return to normal.

Expected behavior

GraphQL queries are unaffected when a new schema called content is created.

Minimal reproduction of the problem

Create a new schema called content.


  • [x] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [ ] Cloud version



I have solved it, the build is running at the moment.

The docker tag name is dev-5137

1 Like

Great, thanks!

For now I’ve simply avoided using that name so I can continue but good to know a fix is coming :smile:

Great. The problem was that “Content” is already used for the content interface. A graphql interface that is shared by all content types.

So in this case, I call the graphql type “ContentEntity”.

I have also added more logging for this case.

This topic was automatically closed after 2 days. New replies are no longer allowed.