[SOLVED, DUPLICATE] Referencing Schema Contents With Total is not working

I have…

  • [ ] Checked the logs and have uploaded a log file and provided a link because I found something suspicious there. Please do not post the log file in the topic because very often something important is missing.

I’m submitting a…

  • [ ] Regression (a behavior that stopped working in a new release)
  • [x] Bug report
  • [ ] Performance issue
  • [ ] Documentation issue or request

Current behavior

I have company and company-jobs schemas. Each company-jobs will reference to a company so that I use referencingSchemaContentsWithTotal to get the total number of company-jobs that a company has. Before it worked fine, but these days it doesn’t work anymore. Now when I use referencingSchemaContentsWithTotal, total will return = 0. Check my screenshots below.

Expected behavior

total should greater than 0

Minimal reproduction of the problem

For example:
There is a company-jobs that is referencing to XCMG company.

But here, XCMG company has 0 company-jobs.

Only SK Automation company, which is the last company that I added, returns the correct data - others return 0.


  • [ ] Self hosted with docker
  • [ ] Self hosted with IIS
  • [ ] Self hosted with other version
  • [x] Cloud version

Version: [VERSION]


  • [x] Chrome (desktop)
  • [ ] Chrome (Android)
  • [ ] Chrome (iOS)
  • [ ] Firefox
  • [ ] Safari (desktop)
  • [ ] Safari (iOS)
  • [ ] IE
  • [ ] Edge

It is a duplicate of this one: [SOLVED] GraphQL referencing returning empty array

The underlaying bug has been fixed but I have to migrate the data. WIll do it soon.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.