[SOLVED] Does not show error while uploading image asset with invalid file extension


#1

Hi Team,

I’ve added Image field with type “Assets” under multiple contents.

While I’m uploading any new image or giving link to any existing image then receiving “Failed to update content. Please reload” error at the bottom. Without uploading image it’s working.

Could you please help me?

image


#2

Do you have some logs or so? I am working on the assets at the moment and uploading so many of them for testing and never had problems.


#3

@Sebastian Thanks for prompt response.

Nope I don’t have any log. May I know on cloud from where I can get error log?

I tried again but still receiving same error. Actually yesterday also I’d tried multiple times but received same error.


#4

You have not mentioned that it is under the cloud :wink:

Can you send me the asset?


#5

@Sebastian :slight_smile:

Find the asset


#6

It works on my app and there is nothing in the logs. Can you check your browser logs / network tab?


#7

@Sebastian, I’ve tried to upload from both browser Chrome & FF. Receiving same error.

Find the below error of Chrome browser under console.


#8

Can you paste the url please?


#9

URL of error :
https://cloud.squidex.io/api/content/cannoliking/blogdata/d3842c54-617d-4f20-8e00-ab746a905dc1?asDraft=false


#10

I see the following error in the logs: Failed to update content: Image[1]: Invalid file extension."

It seems, that it is not shown correctly in the UI.


#11

@Sebastian
As you provided actual error message so I got an idea. The reason is that in field I’ve set
Allowed Extensions like “.jpeg”, “.jpg” but actually Squidex need extension like “jpeg”, “jpg”
format.

I applied Allowed Extensions changes & now it’s working fine.

Thank you very much for all your help promptly.


#12

I found the problem and it will be deployed today or tomorrow.


#13

@Sebastian Thank you very much for all your help.


#14

Fixed and deployed …


#15