[SOLVED] Disable feature is not working for reference fields

Hi Sebastian,

If we configure a reference field as disabled like the course field

It’s not getting disabled when we create or edit the content.

The other thing that I have noticed is If I click the save button then the field is getting disabled.

Thanks & regards,
Waseem Ahmad

Weird, I will have a look.

I cannot reproduce it, which version do you use?

Please use the template next time.

It’s working fine for list control; the issue is coming for dropdown and other controls. I have tested it on https://cloud.squidex.io/.

Perhaps I have already fixed it by accident but the screenshot above shows all reference controls.

Edit: I can also not reproduce it in the cloud.


Feel this is related to this issue but let me know if you want a separate issue raised instead (or if it isn’t an issue!). We’re currently using fd2b2eb7e28463ed26847f1ff347f3ef583958e4 (“Bring back fullscreen mode and add expansed mode”) and can confirm disabling of reference dropdown and list editors is working as expected for us. However I tested a few other field types and editors and some still seem to be enabled:

References field - Checkboxes editor

References field - Input editor

Component field


Currently building a base image against latest master so I can check if these issues have been fixed in one of the many changes since build I tested against.

Best regards,

I can reproduce it now and have pushed a fix.


This topic was automatically closed after 2 days. New replies are no longer allowed.