[SOLVED] Custom User are not able to delete the Draft version

Hi there,

I am using Squidex version 6.4 and having a custom users or editors.

They do not have permission to delete the article content. However, they are able to create, change status, update and create/delete the draft version. here are the settings

Now, the problem I got is they are not able to delete the draft version.

For example, as you can see, here is a draft version they created


But when I clicked to “Delete this version”, I am not able to delete it and I got the following notification


Also, they are not allowed to delete content but under the action button, the delete button is still visible. Is that the default behaviour?


I read from here https://medium.com/squidex/introducing-the-new-permission-system-13ff1df0a87c

And found that

Did I miss something else? Could you please support me?

Many thanks

Can you sen me a backup of your app?

I think it is a bug, there is the wrong permissions: https://github.com/Squidex/squidex/blob/master/backend/src/Squidex/Areas/Api/Controllers/Contents/ContentsController.cs#L616


sorry what do you mean? I am afraid I cannot share it with you :frowning: or I misunderstood


I did change the permissions for deleting the draft but it does not work.

Basically, I tried with two tests

Remove version.delete.own and keep version.delete => it does not work
Remove version.delete and keep version.delete.own => it does not work

Any ideas? Thank you for your prompt supports

Forget the request with the backup.

As I said: It is bug, you cannot do anything.

1 Like

You can try dev-6803 if you want.

1 Like

Hi Seb,

Thanks for support.

I am now finding that the custom editors are not able to delete the Draft version.

For example, I have created a draft version, however there is no delete option for me to delete that draft version. Is this a new bug? or the delete version button is overridden by Global Delete permission, isnt it? You can see at the following image


Please support us

Many thanks

This quote with UI elements not being removed is not true anymore. Can you just send me a backup of your app then I can try it again.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.